Retrouver la petite maison du bouton Accueil de Mystique

0

Foxprime

Cinéphile obsessionnel élevé au doux son des flingues et des répliques cultes de Predator ou Die Hard dont je suis définitivement fan. Passionné d’informatique au stade d’addiction, j’aime parler des choses qui m’intéressent avec franc parlé et sans langue de bois. Également amateur sur le déclin de jeux-vidéo sur lesquels je fais un peu d’actu sur les, de plus en plus rares, sorties qui valent le coup d’œil.

Bio complète

Vous aimerez aussi...

23 réponses

  1. Florian dit :

    Je confirme cher Foxprime tu as juste à jouer sur le lien lol. Et elle est bien cette petite maison 😉

    0

  2. Noellitto dit :

    Bonjour Foxprime,

    Si tu veux allez plus loin, il te manque un bout de code 🙂
    Car normalement, cette fameuse maison semble éclairée (la porte) quand on se trouve sur l’accueil et s’éteint quand on la quitte (article, catégorie et page).

    Comme je suis gentille aussi, je vais te donner ce qui te manque 😉
    Le seul truc, c’est que je ne sais pas si mon code va passer 🙁

    /* custom home icon */
    .menu-accueil.active > a,
    .menu-accueil.active-parent > a{
      background: transparent url(../images/icons.png) no-repeat -46px -6px;
    }
    0

  3. Foxprime dit :

    Bonjour,

    Sauf erreur de ma part, votre code ne fonctionne pas. En plus de ne rien changer en homepage, la maison disparait lorsqu’un article est ouvert.

    0

  4. Noellitto dit :

    Bonjour Foxprime,

    Bizarre cette histoire ! Cette manip’, je l’ai faite en local (sur la version 3.3.2), car celle que j’utilise (2.4.3) n’a pas ce souci …
    La maison est bien présente sur toutes les pages/articles avec ce code !
    Ceci dit, je l’ai fait via le thème enfant “Mystique-Extend” et directement dans la feuille de style. Je viens de tester en désactivant l’enfant pour passer sur le parent. J’ai collé le code dans le CSS de l’utilisateur de Mystique et tout fonctionne correctement …

    As-tu modifié quelque chose dans le dossier image de Mystique ?
    Les 2 maisons se trouvent dans le même fichier “icons.png”.

    Je suppose aussi que tu as bien complété l’adresse :

    background: transparent url(http://www.foxprime.net/wp-content/themes/mystique/images/icons.png) no-repeat -46px -6px;

    Ce que je comprends pas, c’est pourquoi la maison disparait ???

    0

  5. Noellitto dit :

    Je sais pas si c’est ça que tu demandes, mais le code “original” se trouve dans “core.css” lui même situé dans le dossier “CSS” de Mystique 😉

    Le voici :

    /* home icon */
    .nav-main .menu-home a{
      background: transparent url(../images/icons.png) no-repeat -46px -56px;
      padding-left: 32px;
    }
    
    /* home icon */
    .nav-main .menu-home.active > a,
    .nav-main .menu-home.active-parent > a{
      background: transparent url(../images/icons.png) no-repeat -46px -6px;
    }
    

    Et celui modifié pour le nouveau menu (changé “.nav-main .menu-home” par “.menu-accueil”) :

    /* Custom home icon */
     .menu-accueil a{
     background: transparent url(../images/icons.png) no-repeat -46px -56px;
     padding-left: 32px;
     }
    /* Custom home icon */
     .menu-accueil.active > a,
     .menu-accueil.active-parent > a{
     background: transparent url(../images/icons.png) no-repeat -46px -6px;
     }
    0

    • Foxprime dit :

      Cette fois, pas d’erreur à signaler lorsque je c/c votre code modifié complet (bizarre puisque j’avais ajouter le votre à la suite du miens, allez comprendre) mais pas de maison allumée, du moins la porte si ma mémoire est bonne.

      0

  6. Noellitto dit :

    Oui, la porte est blanche à l’accueil pour la version 3.3.2, verte sur la 2.4.3, et devient noir sur les autres pages …

    Des bizarreries j’en ai rencontré des tas entre le blog installé en local et celui hébergé !
    Des codes qui ne passent en local mais reconnus sur l’autre et inversement …

    J’étais tombée sur un article de blog (je ne sais plus où) qui déconseillait le local et préconisait plutôt d’installer le blog test sur le même serveur que notre blog.
    Il expliqué comment faire et pourquoi c’était mieux … Je peux essayer de le retrouver si ça t’intéresse 😉

    Autrement, essaie de voir si le code passe bien, directement sur celui en ligne, des fois que …

    0

    • Foxprime dit :

      Je rencontre moi-même des évènements sur-naturels entre mon blog local et mon blog online donc je ne peux qu’approuver la théorie que vous avez pu voir. Oui si vous retrouvez le site je suis preneur mais que ça ne vous dérange pas 😉

      0

  7. Noellitto dit :

    Et bien un coup de chance ! J’ai eu la bonne idée de l’enregistrer dans mes marque-pages !
    Donc pas de souci 😉

    Et cerise sur le gâteaux j’ai 2 sites pour le même prix 🙂 On sait jamais ! Des fois que les explications de l’autre seraient plus claires ou plus appropriées …
    Le 1er :
    http://chezmat.fr/monter-un-site-de-test-wordpress/

    Le 2ème :
    http://lashon.fr/tester-monter-son-site-web-sans-risque-safe-internet/

    0

    • Foxprime dit :

      Ah merci, j’irai voir ça 🙂
      Dites-moi à tout hasard, sauriez-vous comment modifier le bouton “read-more” ? Je n’aime pas son apparence sur la V3 et j’aimerai modifier ça si possible. Merci 🙂

      0

  8. Noellitto dit :

    Oui, je sais comment faire 😉
    Tu veux faire quoi exactement ? Un effet 3D ?
    Ou simplement changer la couleur ?

    Je te poste le code ici ou bien sur ta page contact ?

    0

    • Foxprime dit :

      A la base juste changer le texte mais toutes les possibilités sont bonnes à prendre. Mettez-les où vous le souhaitez et j’en ferai probablement un article par la suite avec votre accord 😉

      0

  9. Noellitto dit :

    Pour la modification du texte, il y a plusieurs possibilités 😉 Ce n’est plus du CSS mais du PHP que l’on bidouille !
    Perso, j’étais passé par “Poedit” en modifiant la traduction du thème comme cela j’évitais de modifier des fichiers “sensibles”.

    Tu peux aussi le faire au “coup par coup” en modifiant la balise “more” de chaque article ! Pour cela il faut que tu passes en “html” :

    Devient :

    Tu mets le texte que tu veux bien sûr 😉

    0

  10. Noellitto dit :

    Oups le code n’est pas passé 🙁
    De plus j’ai dû enlever du texte car impossible d’avoir le bouton “Poster un commentaire” !

    Le code à modifier “!–more–” devient “!–more Cliquez pour lire la suite–”
    Ou sinon pour le faire une bonne fois pour toute et sans modifier quoi que se soit, tu vas dans les Paramètres avancé de Mystique et dans le “Code défini par l’utilisateur” tu copies/colles ce code :

    // Ajouter l'attribut nofollow et retirer la balise #more du lien "read more"
    function werewp_custom_morelink() {
        return 'Voulez-vous en savoir plus ?';
    }
    add_filter( 'the_content_more_link', 'werewp_custom_morelink' );

    C’est du 3 en 1 trouvé sur ce blog :
    http://jeremyherve.com/2011/01/27/tutoriel-ameliorer-le-lire-la-suite-de-wordpress/

    Maintenant si tu veux aussi modifier son aspect, le codes CSS sera différent en fonction de ce que tu souhaites obtenir 😉

    0

    • Foxprime dit :

      Je vois que nous avons les mêmes sources, malheureusement, ce code me provoque une erreur en local:

      Parse error: syntax error, unexpected '< ' in C:\wamp\www\wp-content\themes\mystique-extend\functions-user.php on line 14

      Précisions, je ne veux pas d'un read more à saisir systématiquement à la main mais qui s'adapte à tous, rétroactif y compris. Je vais voir pour la modif' du fichier de traduction ;)

      0

  11. Noellitto dit :

    Coucou Jérémy,

    J’ai testé ce code en local également et je n’ai pas eu cette erreur ! Tout fonctionne correctement et de plus complètement rétroactif comme tu le souhaites 😉
    Je suis pas une as en PHP, je ne fait que bidouiller mais à mon avis cette erreur provient soit d’un copier/coller tronqué d’un bout de code ou alors de quelque chose que tu as mis avant ce code …
    Essaies ce code uniquement pour voir si c’est vraiment lui qui provoque cette erreur 😉

    Pour ma part, j’ai dans le même fichier “functions-user.php”, ce code + celui de la barre de recherche …

    Autrement, j’ai parcouru rapidement le fichier “fr_FR.po” et j’ai pas trouvé le texte que tu souhaites modifier 🙁

    Va falloir soit se servir du filtre WordPress ou alors trouver et corriger l’erreur de ton “functions-user.php” !

    0

    • Foxprime dit :

      Cette fois ça fonctionne, l’erreur venait de moi.
      En effet, j’avais déjà du code en place et les balises php en double ne passait évidemment pas. Voilà ce qui arrive quand on fait ça rapidement sans faire gaffe héhé.

      Je vous remercie beaucoup pour votre aide 🙂

      0

  12. Noellitto dit :

    Ah ! Et précision IMPORTANTE, ne pas se servir du code que j’ai donné en commentaire “#15” celui n’est pas correctement passé !!!
    Il vaut mieux le prendre directement à la source 😉

    0

  13. Foxprime dit :

    Pour des raisons que j’ignore, le code s’est soudainement mis à fonctionner aujourd’hui alors que je n’ai strictement rien fait d’autres que la dernière fois… J’ai édité l’article en ajoutant votre astuce. Merci 😉

    0

  14. Noellitto dit :

    Les grands mystères “Mystique” … En tout cas, bien contente que cela fonctionne … enfin 😉

    0

  15. MastaFlex dit :

    Bonjour, pour retrouver la maison d’accueil, une manip simple 😉
    Après avoir créé un menu personnalisé il faut juste :
    -ajouter un lien dans le menu personnalisé avec l’onglet “lien”
    -remplir les champs “adresse web” par “l’adresse de votre site” et “cible” par “Home”
    (important de mettre Home avec un H majuscule )!
    – cliquer sur “ajouter au menu”

    voilà vous retrouvez un page d’accueil des article avec la maison 😉 avec le tire Home (défaut de l’anglais)
    #massire

    0

    • Foxprime dit :

      Bonsoir,

      Merci pour le partage 🙂
      Le problème étant pour ma part réglé avec “notre” méthode je n’ai pas pu tester. En attendant les retours d’autres membres.

      0

Un petit commentaire ?